gfxgfx
 

Einloggen mit Benutzername, Passwort und Sitzungslänge
 
gfx gfx
gfx
3585 Beiträge in 637 Themen von 6286 Mitglieder - Neuestes Mitglied: Taibraacinymn September 16, 2019, 03:57:25 Vormittag
*
gfx* Übersicht Forum Hilfe Suche Kalender Donations Einloggen Registrieren gfx
gfx
Forum von WarumDarum.de  |  Battlefield  |  Allgemeines  |  Patch 1.41
gfx
gfxgfx
 

Autor Thema: Patch 1.41  (Gelesen 2972 mal)

ForrestFunk

  • Viertel Member
  • ***
  • Karma: 3
  • Offline Offline
  • Beiträge: 167
  • wenn de Mittwoch ?berlebst......... ist Donnerstag
    • Profil anzeigen
Patch 1.41
« am: November 17, 2006, 19:21:16 Nachmittag »

Mal gespannt was das dingen so bringt. Hat ja aber mal wieder f?r ne ganze menge ?rger gesorgt, he.

Vielen Dank Fl?ster f?r den Torrent und die News... w?re sonnst an mir vorbei gegangen!
Gespeichert
Man sagt: Spielt man eine Windows ME CD r?ckw?rts ab, h?re man satanistische Botschaften.
Ich hab eine viel schlimmere enteckung gemacht: Spielt man sie vorw?rts, installiert sich Windows ME !!!!

Mein System: Core2Duo E6300 -:- Geforce 8800 GTS -:- 2048 MB DDR2 -:- 400 GB HDD

ProfAbsurdis

  • Globaler Moderator
  • alter Hase
  • *****
  • Karma: 9
  • Offline Offline
  • Beiträge: 324
  • Traue nie einer Pflanze,es k?nnte ein Bush sein.
    • Profil anzeigen
    • the OutLaws
Re: Patch 1.41
« Antwort #1 am: Januar 01, 2007, 22:58:30 Nachmittag »

Mit dem Patch und Suse Linux 9 geht es insgesamt nicht so sehr gut. Bei unserer Version fehlt die libstdc++-3.4.2-6.fc3.i386.rpm und da ich nicht gerne in einem laufenden System rumoperiere, habe ich mir folgendes ?berlegt:
Die Installer.sh-Datei l??t sich aufgrund der o.g. fehlenden Systemdatei nicht ausf?hren. Da ich nicht der Linux-Kenner bin, habe ich auf meinem PC auch nur Windows und kann die SH-Datei auf meinem Rechner auch nicht ausf?hren. Was aber m?glich w?re, ist mir die Windows-Serverversion zu besorgen, diese auszuf?hren und die .exe gegen die start.sh (eben alles was Linuxseitig anders ist) auszutauschen.
Sollte doch funktionieren, wenn ich das Ganze dann hochlade und gegen die vorherige Version austausche, oder? W?re sch?n, wenn mir jemand diese Dateinen zukommen lassen k?nnte.
Ideal w?re nat?rlich, wenn ein Linux-User den Inhalt der Install.sh in ein gzip oder tar-Archiv packen k?nnte. Einen FTP zum hochladen w?r kein Problem.
Ich hoffe auf rege Beteiligung.  :oN| :oN|
THX im Voraus.
Gespeichert
Last Night i met the Doctor of Madness, but he would not let me use his Equipment.

AndyGR42

  • Globaler Moderator
  • Anw?rter
  • *****
  • Karma: 5
  • Offline Offline
  • Beiträge: 83
  • Wer tanzt, stirbt nicht!
    • Profil anzeigen
    • Gockeltown
Re: Patch 1.41
« Antwort #2 am: Januar 02, 2007, 21:27:55 Nachmittag »

Nabend.

Schau erstmal nach welche Version installiert ist:

rpm -qa|grep libstdc
Ist die Bibliothek zu alt oder fehlt v?llig sucht nach einen aktuelleren und passenden Version. Fehlt sie v?llig solltest Du zuerst schauen welche von yast angeboten wird. Neuer Versioen k?nnen durchaus abw?rtskompatibel sein und auch funktionieren.

http://www.rpmseek.com

Ich w?rde folgende empfehlen:

http://rpmseek.com/rpm/libstdc%5C%5C-3.4.2-6.fc3.x86_64.html?hl=de&cs=libstdc%5C%5C:PN:0:0:0:0:1806220

In der Regel ist nur die produktive Version der Bibliothek installiert. Es kann sein dass es noch ein DEVEL Version gibt.
Nun muss die installierte Bilbiothek entfernt werden. Das macht man bei SuSE mit yast (empfohlen) oder so:

rpm -e <packet_name> [--nodeps]
Solltes es ohne den Switch --nodeps zu Abh?ngigkeitsproblemen kommen muss er eingef?gt werden.

Nun wird die neue Version installiert:

rpm -i <packet_name>
Treten hier Abh?ngigkeitsprobleme auf sollten diese NICHT ignoriert werden!

Viel Gl?ck,

Andy
Gespeichert

Nolo

  • Frischling
  • *
  • Karma: 0
  • Offline Offline
  • Beiträge: 4
    • Profil anzeigen
Re: Patch 1.41
« Antwort #3 am: Januar 03, 2007, 12:11:15 Nachmittag »

Hallo Andy,

vielen Dank das du sofort auf Proof seinem Tread geantwortet hast.

?ber Yast habe ich alle Updates gefahren. Es wird f?r Suse 9.3 nur die Version der Bibliothek 5 angeboten. Ab Version 10 ist die 6 Standard. Den Hinweis von Dir, die Bibliothek 5 zu l?schen und die 6 zu instalieren h?re ich hier das 1. mal. Dies klinkt aber logisch.

Wenn die  Bibliothek 6 abw?rtskompatibel ist , m??te es normalerweise keine Abh?ngigkeitsprobleme geben. Eine weitere Frage stellt sich, was ist mit unserem BF1942 Server. Auch hier sollten Abh?ngigkeiten bestehen, oder ??? Denn hier kann die Abh?ngigkeit zu 5 bestehen. Es sind also wie Du siehst noch Fragen offen. Ich w?rde mich bez?glich der noch offenen Fragen gerne mit Dir im Teamspeak unterhalten. Ich w?rde mich freuen, wenn Du heute um ca.20:30 Zeit h?ttest. Ich bedanke mich jetzt schon mal f?r Deine Hilfe.


Gru? / F4E|Nolo

Noch eine L?sung w?re, wir w?rden von unseren laufenden Server ein ein Backup machen und w?rden dann uns Suse 10.2 drauf spielen lassen. und dann die Server wieder zur?ckspielen..





Gespeichert

AndyGR42

  • Globaler Moderator
  • Anw?rter
  • *****
  • Karma: 5
  • Offline Offline
  • Beiträge: 83
  • Wer tanzt, stirbt nicht!
    • Profil anzeigen
    • Gockeltown
Re: Patch 1.41
« Antwort #4 am: Januar 03, 2007, 15:17:49 Nachmittag »

Hi.

Man kann auch Bibliotheken verschiedener Versionen parallel installieren. Das funktioniert jedoch mit RPM nur selten, da Dateikonflikte zu erwarten sind. Du kannst auch die alte lib mit ihren symlinks sichern und sp?ter wieder in das Verzeichnis kopieren.

Ob ich heute Abend hier bin kann ich noch nicht sagen. Ich bin in L?beck.  ;D

MfG

Andy
Gespeichert

ProfAbsurdis

  • Globaler Moderator
  • alter Hase
  • *****
  • Karma: 9
  • Offline Offline
  • Beiträge: 324
  • Traue nie einer Pflanze,es k?nnte ein Bush sein.
    • Profil anzeigen
    • the OutLaws
Re: Patch 1.41
« Antwort #5 am: Januar 03, 2007, 17:34:52 Nachmittag »

Ich bin in L?beck.? ;D
Sauft ned soviel  ;D ;D
Gespeichert
Last Night i met the Doctor of Madness, but he would not let me use his Equipment.

Fluestertuete

  • Administrator
  • alter Hase
  • *****
  • Karma: 6
  • Offline Offline
  • Beiträge: 439
  • Morgen wird heute schon gestern sein.
    • Profil anzeigen
Re: Patch 1.41
« Antwort #6 am: Januar 04, 2007, 18:28:19 Nachmittag »

Hicks...  X:|P
Gespeichert
Aktueller Verbrauch meines "Fortbewegungsmittels":



Nolo

  • Frischling
  • *
  • Karma: 0
  • Offline Offline
  • Beiträge: 4
    • Profil anzeigen
Re: Patch 1.41
« Antwort #7 am: Januar 05, 2007, 15:34:23 Nachmittag »

Ich warte bist Du n?chtern bist. Ich w?rde gerne diese Aktion mit Dir durchf?hren. Danke / Nolo
Gespeichert

AndyGR42

  • Globaler Moderator
  • Anw?rter
  • *****
  • Karma: 5
  • Offline Offline
  • Beiträge: 83
  • Wer tanzt, stirbt nicht!
    • Profil anzeigen
    • Gockeltown
Re: Patch 1.41
« Antwort #8 am: Januar 08, 2007, 17:05:17 Nachmittag »

So, ich bin wieder da und auch aufnahmebereit.  ;D BTW, die Idee mit dem Upgrade auf 10.x ist so falsch nicht. Ich habe neulich fast zwei Tage mit 9.3 herumgepopelt um festzustellen das die Kernelversion nicht kompatibel ist....  Der Mist lies sich nicht mal kompilieren.  :>>B War allerdings ein anderes Programm, aber die libstdc++ ist auch nicht mit jeder Kernel Version kompatibel, vor allem wenn es einen Versionssprung gibt. So wie hier, von 5 auf 6.
« Letzte Änderung: Januar 08, 2007, 17:11:21 Nachmittag von AndyGR42 »
Gespeichert

Nolo

  • Frischling
  • *
  • Karma: 0
  • Offline Offline
  • Beiträge: 4
    • Profil anzeigen
Re: Patch 1.41
« Antwort #9 am: Januar 14, 2007, 11:35:37 Vormittag »

Hi Andy,

wie Du schon schreibst, kann es zu Abh?ngigkeiten kommen und bei einen Versionsprung von 5 auf 6 zu Problemen mit der Kernel bzw. Abh?ngigkeitsproblemen kommen. Genau dies ist so gekommen.

Folgenden Installation wurde vorgenommen.

ipx10123:/home/bf2server/downloads/libstdc++-3.4.2-6.fc3.i386 # rpm -ihv ./libstdc++-3.4.2-6.fc3.i386.rpm
warning: ./libstdc++-3.4.2-6.fc3.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
Preparing...                ########################################### [100%]
   1:libstdc++              ########################################### [100%]
ipx10123:/home/bf2server/downloads/libstdc++-3.4.2-6.fc3.i386 #

Die 5er Version war gel?scht. Installation verlief reibungslos. Nun trat das geahnte auf , es gab Abh?ngigkeitsprobleme von 7 Abh?ngigkeiten :

1: Paketabh?ngigkeiten                        -----------+
 +---------------------------------------------------------------+ menfassung -
 ?     ?Paket/Bibliothek?Art der Abh?ngigkeit       ?Zus?tzliche - zliche Doku?
 ?     ?/usr/bin/python ?wird ben?tigt von...       ?(/usr/bin/py? zliche Doku?
 ?  i  ?python          ?ben?tigt ...                            ? documentati?
 ++---------------------?----------------------------------------+ al Linux bo?
 ... dem/n unten aufgef?hrten Paket(en)                            ok: The Def?
                                                                   macs Lisp R?
 +---------------------------------------------------------------+ ard der Dat?
 ?     ?Name  ?Zusammenfassung                                   ? -----------+
 ?  i  ?python?Python Interpreter                                ? :
 ?                                                               ? -----------+
 +---------------------------------------------------------------+            ?
         
  • Ausw?hlen    [-] L?schen    [>] Aktualisieren                    ?

                                                                              ?
 [ L?sen ]  [ Alle ignorieren ]  [ Ignorieren ]  [ Abbrechen ]   



     ?Paket/Bibliothek?Art der Abh?ngigkeit       ?Zus?tzliche ? zliche Doku?
 ?  i  ?python          ?ben?tigt ...                            - zliche Doku?
 ? -i- ?libstdc++       ?wird ben?tigt von...     


 -i- ?libstdc++       ?wird ben?tigt von...       ?(Version 3.3? zliche Doku?
 ? -i- ?libstdc++       ?muss neu installiert werden?(libstdc++ w- documentati?
 ++---------------------?----------------------------------
                                                                  macs Lisp R?
 +---------------------------------------------------------------+ ard der Dat?
 ?     ?Name                 ?Zusammenfassung                    - -----------+
 ?  i  ?ImageMagick          ?Viewer and converter for images    ? :
 ?  i  ?db                   ?Berkeley DB Datenbank-Bibliothek 


Unter dieser Veraussetzung kam die Enstscheidung, an diesem Punkt nicht mehr weiter zumachen.  In diesen Problemen war unser Server  BF1942 noch nicht ber?cksichtigt. Denn dieser h?tte neu gestartet werden m?ssen um zu sehen ob dieser Hochf?hrt und es auch Problem gibt.

An dieser Stelle kann man entscheiden: 1: Die Abh?ngigkeiten zu Ignorieren und somit in Kauf nimmt, dass Programteile von yast 2 nicht mehr funktionieren oder unter L?sung weitermacht.

Die Entscheidung ist unter "L?sung" weiter zu machen gefallen. Das Ergebnis war, Yast hat die 5er Version wieder installiert. Ich mu? hier an dieser Stelle sagen, dass ich auf keinen Fall eine Gefahr f?r den BF1942 Server eingehen wollte.

Ich habe mich entschieden, den Vorschlag zu machen, ein Update von Suse 9.3 auf 10.2 zu machen. Wobei ich aber auch  Debian Sage 3.1.a, die als sehr stabil gilt zu installieren.

Es steht nur eine wichtige Frage noch im Raum, die w?re: l?uft BF1942 mit der Version suse 10.2  / Debian Sage 3.1.a ?

Gru? / Nolo












Gespeichert

AndyGR42

  • Globaler Moderator
  • Anw?rter
  • *****
  • Karma: 5
  • Offline Offline
  • Beiträge: 83
  • Wer tanzt, stirbt nicht!
    • Profil anzeigen
    • Gockeltown
Re: Patch 1.41
« Antwort #10 am: Januar 14, 2007, 12:11:56 Nachmittag »

Moin.

Also, SuSE 10.2 habe wir noch nicht im Einsatz. Wir haben zwei BF1942 Server auf 10.1 laufen. Davon einen stabil und einen weniger (Midway). Ich habe noch nicht herausgefunden warum der Midway Server solche Zicken macht. Es ist allerdings auch ein anderer Hoster und damit eine andere, wie ich finde nicht unbedingt gelungene, Grundinstallation. Debian nutzen wir gar nicht. Mir reicht es schon das wir SuSE von 9.0 bis 10.1 haben....

Viel Erfolg.

Andy

Gespeichert

ProfAbsurdis

  • Globaler Moderator
  • alter Hase
  • *****
  • Karma: 9
  • Offline Offline
  • Beiträge: 324
  • Traue nie einer Pflanze,es k?nnte ein Bush sein.
    • Profil anzeigen
    • the OutLaws
Re: Patch 1.41
« Antwort #11 am: Januar 14, 2007, 12:47:44 Nachmittag »

So ein Aufwand wegen BF2.  :>>B
Die sind zu dusselig einen patch zu programmieren.  Ich meine immer noch: die Patch-Files packen, hochladen, entpacken und fertig....
Gespeichert
Last Night i met the Doctor of Madness, but he would not let me use his Equipment.
Forum von WarumDarum.de  |  Battlefield  |  Allgemeines  |  Patch 1.41
 

gfxgfx
gfx gfx
Powered by MySQL Powered by PHP Prüfe XHTML 1.0 Prüfe CSS